nix/overlays/default.nix

19 lines
512 B
Nix

{ inputs, ...}: {
# This one brings our custom packages from the 'pkgs' directory
additions = final: prev: import ../pkgs final.pkgs;
# This one contains whatever you want to overlay
# You can change versions, add patches, set compilation flags, anything really.
# https://nixos.wiki/wiki/Overlays
modifications = final: prev: {
};
unstable-packages = final: _prev: {
unstable = import inputs.nixpkgs-unstable {
system = final.system;
config.allowUnfree = false;
};
};
}