37 lines
804 B
Nix
37 lines
804 B
Nix
{ config, lib, ... }:
|
|
|
|
with lib;
|
|
|
|
let
|
|
cfg = config.settings.hardware.locale;
|
|
in {
|
|
options = {
|
|
settings.hardware.locale.enable = lib.mkOption {
|
|
type = lib.types.bool;
|
|
description = ''
|
|
Enable locale configuration
|
|
'';
|
|
};
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
# Set your time zone.
|
|
time.timeZone = "Europe/Amsterdam";
|
|
|
|
# Select internationalisation properties.
|
|
i18n.defaultLocale = "en_US.UTF-8";
|
|
|
|
i18n.extraLocaleSettings = {
|
|
LC_ADDRESS = "nl_NL.UTF-8";
|
|
LC_IDENTIFICATION = "nl_NL.UTF-8";
|
|
LC_MEASUREMENT = "nl_NL.UTF-8";
|
|
LC_MONETARY = "nl_NL.UTF-8";
|
|
LC_NAME = "nl_NL.UTF-8";
|
|
LC_NUMERIC = "nl_NL.UTF-8";
|
|
LC_PAPER = "nl_NL.UTF-8";
|
|
LC_TELEPHONE = "nl_NL.UTF-8";
|
|
LC_TIME = "nl_NL.UTF-8";
|
|
};
|
|
};
|
|
}
|